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General Notes

SIMCom offers this information as a service to its customers, to support application and engineering
efforts that use the products designed by SIMCom. The information provided is based upon
requirements specifically provided to SIMCom by the customers. SIMCom has not undertaken any
independent search for additional relevant information, including any information that may be in the
customer’s possession. Furthermore, system validation of this product designed by SIMCom within
a larger electronic system remains the responsibility of the customer or the customer’s system
integrator. All specifications supplied herein are subject to change.

Copyright

This document contains proprietary technical information which is the property of Shanghai
SIMCom Wireless Solutions Ltd, copying of this document and giving it to others and the using or
communication of the contents thereof, are forbidden without express authority. Offenders are liable
to the payment of damages. All rights reserved in the event of grant of a patent or the registration of
a utility model or design. All specification supplied herein are subject to change without notice at
any time.

Copyright © Shanghai SIMCom Wireless Solutions Ltd. 2013
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Revision history

Revision | Date Description of change Author

1.00 2013-01-11 | Initial MXN

SCOPE

This document describes how to use the IDE tool to develop user’s own application.
Examples are also given for reference. This document can be used for SIM900 serial modules, like
SIM900, SIM900D, SIM900B and SIM900A.

This document is subject to change without notice at any time.
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1 Introduction

SIMDevVIDE is an IDE tool developed by SIMCom to integrate its core Embedded AT environment
with customer’s application development process. SIMDevIDE allows customers to edit, compile,
link core libraries and download MOT file effortlessly. SIMDevIDE works with all versions of
Windows. This document describes how to develop your project in Eclipse IDE.

2 Getting Started
Before installing SIMDevIDE tool, user should install arm complier tool first.

2.1 Install SimDevlde

Uncompress the rar file (e.g.“1137B02V01SIM900A64 ST _EAT.rar”). Execute installation file
(e.g. “SIM900ADevIDE V1.01 (1137B02V01SIM900A64 ST EAT).exe”) and follow the install
instructions.

2.2 Install Java SE Development Kit

Go to the website
http://www.oracle.com/technetwork/java/javase/downloads/jdk7-downloads-1880260.html to
download the latest JDK.

2.3 Install Gece compiler

Go to the website http://www.yagarto.de/ to download YAGARTO Tools and YAGARTO GNU
ARM toolchain. When the user has downloaded these two tools, please install them and note that
these two tools must be only installed in the no-space and only English path.

2.4 Download Eclipse and its plug-in

Go to the website http://www.eclipse.org/downloads/ to download Eclipse IDE for C/C++
Developers and go to the website http://sourceforge.net/projects/gnuarmeclipse/ to download
org.eclipse.cdt.cross.arm.gnu_0.5.4.201202210114.

SIM900 Eclipse environment install Application 4 1/11/2013
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2.5 Install Eclipse environment.

1. Uncompress the zip file (Eclipse IDE for C/C++ Developers) and click “eclipse.exe”.
2. Then select your workspace as following, and then click OK and wait for eclipse initialization.

& Yorkzpace Launcher

Select a workspace

Eclipse =stores wour projects in a folder called a workspace.
Choose a workspace folder to use for thiz session.

DEmbeddedAT

V| [ Browse. ..

Workspace:

Duse thiz as the default and do neot ask again

3. The eclipse IDE will show as following:

& C/CH — Eclipse

File Edit Source Refactor Havigate Search Run FProject Hindew Help

@) Releome 32 oA SRS

Bg ||
- Welcome to the Eclipse IDE for C/C++ Developers

SIM900 Eclipse environment install Application 5 1/11/2013
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4. Install org.eclipse.cdt.cross.arm.gnu_0.5.4.201202210114. Please click “help->install new
software”, and it will show a dialog as following:

& Install |;.|EJ®
Available Software ’_ |

Selact a =ite or enter the location of a =sitae. \_} o
[

-

Nork with:ai e O

Find more software by working with the "Awailable Software Sites” preferences.

Hame Version

D@ There is no site selected.

Select A11 ] [Eeselect A1

Details

Dﬂide items that are already installed
fhat 1= already installed?

Show only the latest wersions of awailable software
Qroup items by category

DShow only software applicable to target enviromment
Eontact all update =sites during install to find required software

@:l { Back

5. Click “Add” and then it will show a dialog as following and click “OK:

Type gnu here.

& idd Repository

Hame: [lg:nu

Location: |_13r file:/TI:/GCCf org. eclipse. cdt. cross. arm. gnu_ 0. 5|

@ 0K || Camesl |

Click  “Archive...” to  select
org.eclipse.cdt.cross.arm.gnu_0.5.4.2
01202210114 location where you
download in Char. 2.4.

SIM900 Eclipse environment install Application 6
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6. Unselect “Group items by category” and select “GNU ARM C/C++ Development Support”,

and then click “Next”.

& Install

Available Software
Checl: the items that wyom wiszh to install. ; =

Work with: !g:nu - jar:file: /T:/GCC/ore. eclipse. cdt. cross. arm. gnu 0.5, 4. 201202210114, zip!/ vl[ Wi ]

Find more software by working with the "Awailable Software Sites” preferences.

Hame

Version

[ [-a?:': GHU AEM C/C++ Development Support ] 0.5.4, 201202210114

» Select this option.

Select A11 ] [ Dezelect A1l

Details

1 1tem selected

Show only the latest wersions of awailable software Dﬂide items that are already installed

Dgroup items by category

]

@

DShow only software applicable to target enviromment

Eontact all update =sites during install to find required software

Unselect this option.

fhat 1= already installed?

SIM900 Eclipse environment install Application 7 1/11/2013
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7. Select “I accept the terms of the license agreement” and click “Finish”.

& Install
Review Licenses [
Licenzes must be reviewed and accepted bafore the zoftware can be installed. \_} __|
') -

License text (for GHU ARM C/C+t Dewelopment Support 0.5.4. 2012022101140

|The "GHU ARM Eclipse Plug—in" iz free software.

|Fermission is hereby granted, free of charge, to any person obtaining a
Ecopy of thiz software and associated documentation files [(the
|"Software”), to deal in the Software without restrictien, including
!without limitation the right=z to usze, copy, modify, merge, publish,
|distribute, sublicense, andfer sell copies of the Software, and to
|permit persons to whem the Software iz furnished to do 5o, subject to

!the following conditions:

\The abowe copyright notice and this permizsion notice shall be included
|in all eopies or substantial portions of the Software.

|THE SOFTHARE IS FROVIDED “AS IS, WITHOUT WARRAWTY OF AWY EIWD, EXPRESS
|OR IMPLIED, INCLUDING BUT HOT LIMITED TO THE WARRANTIES OF
\MERCHANTABTLITY, FITHESS FOR A PARTICULAR FURFOSE AHD

|NONIFFEINGEMENT. IN WO EVENT SHALL THE AUTHORS OR COPYEIGHT HOLDEES BE
|LTABLE FOR AWY CLAIM, DAMAGES OR OTHER LIABILITY, WHETHER IN AN ACTION
|\OF CONTRACT, TORT O OTHERWISE, ARISTHG FROM, OUT 0OF OF IN CONNECTIOR
|WITH THE SOFTWARE OR THE USE OR OTHER DEALINGS IN THE SOFTYARE.

@I accept the termz of the licensze agreement

OI do mot accept the terms of the licensze agreement

@ et Finish | [ Cancel

8. Click “OK”” when the following dialog is shown.

& Security Warning

anthenticity or walidity of this software canmot be established. Do xou

"'_., Warning: You are installing software that contains unsigned content. The
want to continue with the installation?

| 0K ||  Cancel || Details 3> |

9. Wait for install finished. And click “Yes” when the following dialog is shown and wait the
eclipse restarts.

& Software UOpdates &'

You will need to restart Eclipse for the changesz to tale effect. Would you
\_t/ like to restart now?

10. Now we finish the eclipse gun arm plug-in installation.

SIM900 Eclipse environment install Application 8 1/11/2013
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2.6 Import a project

1. Copy “EmbatSIM” folder (which is in the SIMDevIDE tool root path) into eclipse workspace
path. (In this document, the eclipse workspace path is “I:\EmbeddedAT”)

2. Click “File->Import” and select “General-> Existing Projects into Workspace”. And then
click “Next”.

B(=1/3

Select

Create naw projects from an archiwe file or directory. |_E Jg

Select an import source:

[=-[= General
[E, Archive File
'@ Existing Projects into Workspace
|:L File Swstem
EL Freferences

[== CFCH

= C¥3

[~ Git

[~ In=tall

[= Remote Systems

[-=- EFM

[~ Bun/Debug

[ Tasks

[~ Team

[~ Tracing

©

SIM900 Eclipse environment install Application 9 1/11/2013
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3. Click “Browse” to select the project location. The project is located in “SIMDevIDE tool root
path\ eclipse_example”. And there are two projects in this folder. One is using SIMCom libraries
(SampleUseSIMComL.ibs) instead of using GCC C standard running libraries. This project is that
when the core firmware is changed, you must compile your app again. The other one is using
GCC C standard running libraries (SampleWithGccLibs). This project is that when the core
firmware is changed, you don’t need to compile your app again.

Click “Finish”.

- B

Import Projects

Zelect a directory to search for existing Eclipse projects.

'@}Select roor directory: |J:WEIMIODDewIDE_DTMF_MultiTask GCCheclis Browse. ..
lrC:;"Selen:t archiwve file:

Frojects:
SamplelzeSIMComLibs (T: \SIMI0ODewIDE_DTMF_MultiTaslk GCChecli Select All
Dezelect All

Refrezh

e

£ *

[i:-:up}' projects into workspace ]—> Select this ootion.

Working =ets

Dﬁldd project to working sets

Cancel

@ [ Einisn ]

4. If you import “SampleWithGccLibs” project, you don’t need to modify anything, just to
compile it. Note that if you use this project and when the core is changed, you don’t want to
compile your app again, you must call the function point API instead of function API such as
“eat_GetEvent”. Please don’t call “eatl 02GetEvent” function.

If you import “SampleUseSIMComLibs”, you must modify the .x file path. The steps are as
following:

SIM900 Eclipse environment install Application 10 1/11/2013
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a)Click the project which you want to
“SampleUseSIMComL.ibs”.

modify.

select the project

File Edit Sowce Refactor HNavigate Search Project Fun Window Help

e B-&-min ERT - AR RNCASE A R R =N = i S

[ Project Brplorer 2 | H 5 &0 T = 0 g syscalls.c 8

#if defined USE_C_STANDARD LIES £& defined COMP_GCC
#include <stdio.h>

#include <stdlib.h>

#include <string.h>

#include <sys/stat.h>

f> SamplelffihGecLlibs

extern int DebugWrite [const void *buffer, int len);

fdefine STDIN FILENO D /¥ standarc input file descriptor =/

#deflne STDOUT FILENGQ 1 /* Standard output file descriptor */

Se|eCt ;;SamDIeUseSIMcomLibS"naef ne STDERR FILENO 2 /* stamdard error file descriptor */

“void _exit (int n)
{
while (1)
{

n
¥
¥

“int _stat(char *file, struct stat *st) {
return (0j:
3

~int fstat (int fd, struct stat * st
i

if (fd == STDOUT FILENO)

i

memset (st, 0, sizeof (* s5t)):

st->st mode = 5 IFCHR:
st->st_blksize = 10247

return 0O

¥

Adle

Problems &% Tasks L) Console 33

Ho consoles to display st this tine

Proparties

125 SamplelizeSINConLibs

rerer—

a8

I

=
!

=

= [ T =8
Bl R e % w7
M stdioh
stdlib. k
string b
sys/stat h

u
+
#
#
#
2
°
(.
®
°
°
°
e
°
e
e
®

Debughvite(const voidk, int
STOTH_FILERD

STDOUT_FILERD
STOERR_FILENO

_exit(int)  woid

_stat (char¥, struet statk]
_fstat(int, struct stats) .
steck ptr | chark

_sbrk r (void¥, size_t) | ca
isatty(nt) © int
_lseek(int, int, imt) o int
_open (eemst char#, imt) : i
_close (imt) | int
(b, @) o,
_resdlint, woid¥, unsigned
Debughri te(const voidk, int

2013F1E 11 H
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b)Click “Project->Properties” and it will show a new dialog as following. Select “C/C++
build->Settings->ARM Targets Windows GCC C Linker”. And modify the “.x” file
name. The “.x” file is located in “EmbatSIM\gsmos\coreSW\rvctcore” of the Eclipse
workspace. Please find .x file and replace the file name.

€ Properties for SampleUseSINComLibs - E)X]
[ i ] settings G- -
Resource
Builders I \
5 C/CH Build Configuation: | [ ALL configurations ] | [Manage Confi gorations
Build ¥arisbles \¥ J
& Tool Settings | 5 Build Steps j&d Binary Parsers | @ Error Parsers

Tool

‘ (5 Target Frocesser / ‘Commmd. [ar eabi-ld
55 Debuzzin, "
—lizhs 1 nostartfiles —L, Map, SanplelzeSINConLibs. nap —nepu=srnda -mthunb-interwork

Select “All configuration”

(% Warnings
(% Miscell:

C/CH Ge
Froject
Run/Debu;

Task Rep
WikiText

Expert settings
s GCC C Compiler 5;’:’“3;‘1 W/ gsmos/ cor et rveteore/113T _ST_EAT_FOR_HON_2012_1203_1006. =" “${build_project}../ /Emhat‘]
L&

e pattern:

ows GEC C Linker

A 4

ows GHII Create Flash Image

Find the .x file in this line.

=
ows GHUf Create Listing

ene
(=83 ARM YTagarto Windows GHU Print Size

(% Gemeral
Modify this file name according
to your EmbeddedAT firmware
+
@
Expert settings:
Efﬂ’ga‘;gttem: [ "${build project}.. . - /EnbatSIH/ gsmos/ coreSi/rveteor o1 137601 YOI STNGOON125_TNTEL DTHF_JD_EAT.x" |'$ fbuild |

Note: Please don’t delete fl_main, fl_ctrO.s, syscalls.c files. These files are the gcc
environment boot files.

2.7 Compile your project

Click and select the project which you want to compile as following. Click Hammer icon to
compile the project.

If the compilation is completed with no problem, the binary file, with a name of xxx.hex,

will be generated under the Release or Debug directory of the project directory,depending on
which configuration mode you are currently working on.

SIM900 Eclipse environment install Application 12 1/11/2013
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= 2R Q- —m—=%» Click here to compile the project.

%Prnject Explorer &% [—] Q:b e ¥ = H E{

Select the project

= campleiy thizeclibs=

The following is the compiler result:

|._|>_‘|Prl:-ject Explorer &2 [—] % & ¥ = 8

=== Samplelz=SIMConLibs
#:;P Binaries
[}l Includes
[= aine
[= code
[=][= Debug
[=)[= code
fl_ertl. o — [armfle]
fl_customer. o — [armfle]

fl main o - [arm/le]
=l f1_crtl. 4
=| f1_ertd. o. 1=t

fl_customer. d

i)

fl customer. o. 1lst
fl main. d
fl main. o. 1lst
| @ =ubdir. mk
i} SamplelUzeSIMComLibs. e1f - [armile]

i

L@ makefile
| & objects. mk This is the binary file which
. ] »l - -
(] SamplelzeSIMComLibs. hex | > is used to downloaded into
=| SamplellzeSIMComLibs. 1=t the module

g SamplellseSIMComLibs. map

| @ sources. mk

2.8 Add a new file

Click “File->New->Source File” or “File->New->Header File”. It will show the dialog as
following. Click “Browse” to select the path where you want to store the file. In “Source file”
line, please input the file name which you want to add.

SIM900 Eclipse environment install Application 13 1/11/2013
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& NHew Source File

Source File
Create a new source file. C
Source folder: |Smple'|'|'itthcLib5,'rcnde | [ Browse. .. ]

Source file: [|5m5.c | |

J

enplate- \Defiault C source template v || Confifgure. .. |
v
v Click “Browse” to
Input the file name select the path where
which you want to add. you want to store the
file.

@ Finish ||  Cancel

2.9 Add an existing file

1. Click “File->Import” and select “General->File System”, then click “Next”.

SIM900 Eclipse environment install Application 14 1/11/2013
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&= Import |:| |E| [Z'

Select
Import resources from the local file =ystem into an existing project. |_E Jﬁ

,

Select an import source:

[=)[= General
[E, Archive File
@ Existing Frojects into Workspace
|:L File Swstem
EL Preferences

[=- CfC++

[=- C¥5

= Git

[~ Imstall

[= Remote Systems

[-=- EFM

[~ Bun/Debug

[ Tasks

[= Team

[~ Tracing

@

2. Click “From Directory->Browse” to select the file location and select the file which you want
to import. And Click “Into folder” to select the folder which you want to put files into. At last,

SIM900 Eclipse environment install Application 15 1/11/2013
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click “Finish”.

B=1ES

File system F
Import resources from the local file system. i ,.-"
-
From directory: |J': heclipzehLFCHprezzo 5.0 12 1083 'workspace'Test Vagarto 1Z8M_Geec libh w ||[ Browse. . . ]
| —
[F]= code F] @ callTazk. o - |

1 @Context. C
[ |] dis1di5dizplay. c Click here to select

7 i [+] fl_atc. c ) )
Select the files which .l %ﬂ_atc?mess. .: ] the file location.

you want to import. T o EL_atotuens. <
[ [5 f1_erto s
F] @ fl_customer. o
1 @ fl_main. ¢
] |cl f1_mzz. e %
Filter Types... ] [ Select A1l l [ Deselect All l
Into folder: |SampleUseSIMCOmLibs,"code
Options

ngerwrite existing resources without warning

Dgreate top—lewel folder CIle here to Select

the folder which you

want to put the files
in.

@ Finish | [ Cancel

2.10 Download to SIMCom Module
1. Select “Build->Download” menu.
2. Configure the options as below. It is recommended to use the default value for the options

SIM900 Eclipse environment install Application 16 1/11/2013
Note V1.00



A comgany of S84 Tech Smart Machine Smart Decision

Select module type

Confirm the serial
port number in
user’s PC’s Device
Manager.

SERTAL Dewnload ]

Tarzet Fort Baud Bate DownloadOption ReadBufferZi
SIMG00 v | |[COM3 | 460800 v | |Embeddedt v | |2048

Download File
Core File |I:\Embedded.hT"xEmbatSIH'igsmns"ucnreS'ﬁ"‘xrvctc-:-re"xllﬂ =

Select the core file

Time 2013-01-07, 16:45:25 00000000 Size [x3FECOS .
. 2 in the path “..
Note: This P
\EmbatSIM\gsmos\
address ——
Time—2043=04=1—10-47-00 00400000 Size [uAdd coreSW\rvctcore\”.
should be
00400000. Eraze Type!  |Erase User Data and Code ﬂ | I
Select the
application file
Flash Type created in the path.
Note that it is .hex
Start Dowrdoad file.
025 Exit
Refresh COM port
Status:

Figure 11
3. Download user’s application to the module by pressing “Start Download” button.

Note: If user only needs to download the application file, set the “DownloadOption” option to
“NORMAL” and “Erase Type” to “Erase User Data and Code”.

SIM900 Eclipse environment install Application 17 1/11/2013
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Contact us:

Shanghai SIMCom wireless solutions Ltd.

Address: Building A, SIM Technology Building, No. 633 Jinzhong Road, Shanghai,
P. R. China 200335

Tel: +86 21 3252 3300

Fax: +86 21 3252 2030

URL: www.sim.com/wm
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